Skip to Main Content Skip to Site Map

Active Alerts

POODLE vulnerability - An online security vulnerability that may allow secure web connections to be compromised under specific web browsing conditions.

Secure Socket Layer (SSL) is a protocol used to encrypt your personal information when it is being transmitted over the Internet.  This vulnerability, named ‘POODLE’, may allow attackers to decrypt the SSL v3 connection in older browsers. Please note that this is not a vulnerability in our online banking system, but in fact a vulnerability in the SSLv3 protocol itself. In our commitment to your security, and in keeping with industry standards, United Community Bank will no longer support such browsers. Because of the vulnerabilities, if you currently utilize an unsupported browser, please take steps to update your browser, or consider installing an alternate web browser such as Google Chrome or Mozilla Firefox to minimize any negative impact. If you are unsure if your browser is safe, you can visit one of the following sites to check your status:  or

The Bank That SERVICE Built

We are proud to have a #1 customer
satisfaction rating.

(Customer Service Profiles)